cccicl
cccicl
发布于 1个月前

Flutter真机调试找不到设备:ERROR: Could not connect to lockdownd, error code -17

ERROR: Could not connect to lockdownd, error code -17

解决方式:修改var/db/lockdown文件夹的读写权限。

步骤:

Finder 》前往菜单 》前往文件夹》进入/var/db/

找到‘lockdown’ 文件夹 》右键,显示简介 》底部的‘共享与权限’ 项,打开右下角的锁(输入电脑密码)》加号,将自己的账号添加进权限表中,修改自己的权限为‘读与写’ 》锁定权限表即可。

再在终端依次执行以下命令:

brew update

 brew uninstall --ignore-dependencies libimobiledevice

brew uninstall --ignore-dependencies usbmuxd

brew install --HEAD usbmuxd

brew unlink usbmuxd

brew link usbmuxd

brew install --HEAD libimobiledevice

brew install ideviceinstaller

搞定!!!

©2020 edoou.com   京ICP备16001874号-3