发布于 2年前

iPV6换SDK后上传版本报错:ERROR ITMS-90530,ERROR ITMS-90502

①ERROR ITMS-90530: "Invalid MinimumOSVersion. Apps that only support 64-bit devices must specify a deployment target of 8.0 or later. MinimumOSVersion in '****.app' is '7.0'."

中文:无效的最小版本号,支持64位的设备,最小的版本号必须是iOS8 以上,而在****.app 上的版本号是7.0

②ERROR ITMS-90502: "Invalid Bundle. Apps that only contain the arm64 slice must also have 'arm64' in the list of UIRequiredDeviceCapabilities in Info.plist."

③ERROR ITMS-90158: "The following URL schemes found in your app are not in the correct format: [777290058110048]. URL schemes need to begin with an alphabetic character, and be comprised of alphanumeric characters, the period, the hyphen or the plus sign only. Please see RFC1738 for more detail."

④生成的 API 分析文件太大。我们无法在交付前验证您的 API 使用信息。这只是通知信息。

报错① 修改为最低版本iOS 8.0,如果公司非得兼容iOS7 的时候需要检查是那些SDK 只支持iOS8 以后,需要换掉此SDK或者找别的办法,由于现在的我们app 的新增用户iOS8 以下的用户只占5.3% 为了不延误上线时间 直接修改最小版本为IOS8

报错② 本来想在下面的arm7 下面增加arm64 的兼容64位,后来发现增加了,arm64 在iOS8 的手机上无法正常调试安装.总之plist文件不动

报错③ 增加了银联支付,银联的URL schemes 配置不正确,URL schemes 必须以英文字母开头,修改之就ok

报错④ 不管,每次打包都有,不影响审核和上架

相关文章

©2020 edoou.com   京ICP备16001874号-3