发布于 2年前

iOS-执行pod lib lint时候报错 - ERROR | [iOS] unknown: Encountered an unknown error (The 'Pods-App' tar...

执行pod lib lint验证podspec文件是否正确报了一个下面👇的错误

  • ERROR | [iOS] unknown: Encountered an unknown error (The 'Pods-App' target has transitive dependencies that include static binaries: (/private/var/folders/zj/hff3w0_s0fl6rpf291l2btgh0000gn/T/CocoaPods-Lint-20190121-35737-1ilhzdf-AWAdsLib/Pods/FBAudienceNetwork/FBAudienceNetwork.framework)) during validation.

podspec文件中依赖了静态库造成的验证不通过,想要验证通过可以通过添加参数--use-libraries让验证通过,这样操作并不影响pod使用

--verbose 显示检查编译的详细信息
--allow-warnings 验证时允许有警告

执行一下命令:通过验证
$ pod lib lint --verbose --use-libraries --allow-warnings

iso

相关文章

©2020 edoou.com   京ICP备16001874号-3