发布于 9个月前

安装angular-cli1.6.4警告:npm WARN @schematics/angular@0.1.13 requires a peer of @angular-devkit/schematics@0.0.46 but none was installed.

angular-cli升级到最新版本:

$ npm uninstall -g angular-cli
$ npm install -g @angular/cli@latest

最新版本为:Angular CLI 1.6.4

安装后警告提示:

npm WARN @schematics/angular@0.1.13 requires a peer of @angular-devkit/schematics@0.0.46 but none is installed. You must install peer dependencies yourself.
npm WARN @schematics/schematics@0.0.13 requires a peer of @angular-devkit/schematics@0.0.46 but none is installed. You must install peer dependencies yourself.

按提示先安装@angular-devkit/schematics@0.0.46

npm install -g @angular-devkit/schematics@0.0.46

卸载angular-cli后重新安装,仍然报以上警告。

在angular-cli的issue上开了一个bug:[bug] global angular-cli install produces peer warnings

angular1.6.4版有很多问题,已经在angular-cli 1.6.5修复。

©2020 edoou.com   京ICP备16001874号-3