发布于 1个月前

Maven设置项目JDK版本为1.8

导入一个项目到iDEAL,项目中使用到lambda表达式的地方都报错,提示jdk版本不对。

想到的第一种解决方案就是修改iDEAL的配置,修改两处的设置,如下:

File → Settings → Java Compiler → Target bytecode version 改为1.8
File → Project Structure → Modules → Language level 改为 8-Lambdas,type annotations etc.

这样就可以了。后面想了想,是否可以通过maven来设置。

maven在pom.xml配置build添加maven-compiler-plugin插件,设置source为1.8即可,示例如下:

<build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <version>3.6.0</version>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
            </configuration>
        </plugin>
    </plugins>
</build>

通过在maven中设置jdk版本为1.8,这样在其他地方导入项目就不需要手动修改iDEAL了。

©2020 edoou.com   京ICP备16001874号-3